Getting Quick RSVP error, "We're sorry, but something went wrong."

I can RSVP for calendar events, but if I’m not logged in and we try to use the Quick RSVP I receive the following error on a mostly blank webpage.

“We’re sorry, but something went wrong.”
“We’ve been notified about this issue and we’ll take a look at it shortly.”


Is anyone else having this issue?

I’d really love to get it fixed, since I’ve been trying to use the RSVP feature more instead of using paper.
It’s been happening for a couple of weeks. Thanks for the help, I may also submit a support ticket.

I did also notice this issue.

@Keener-Trooptrack, I did a quick search but didn’t find anything else related to this are you aware and have the dev team working on it?

I just went into the event I was testing this on and even though I got the error message it did seem to accept the RSVP status I had selected. Now that I am logged in to TT the RSVP link did work.

Hi @AaronStorey,

Yes I was able to recreate these errors on a ticket that Eric put in yesterday. I got this over to the tech team to have them take a look at it.

Yes, it seems it’s not working if you aren’t logged into TT.


David Keener

Thanks for the update!

Have there been any further updates for this bug? We have been having the same problem.

I have not received any updates yet on the support ticket. I believe they are still working on it.

1 Like

I am also seeing this issue when our troop tries to RSVP from a mobile phone (iPhone using Safari) – fails every time. I was, however, able to RSVP when using the desktop application. It redirected me to login first. However, when on the phone it does not redirect to login.

@EricGunderson any update on this issue?

We’ve been getting the same error message this week. Interesting thing is that it looks like when someone RSVPs, TroopTrack is recording their attendance, and they still get that message.

We are still having that problem also, when people aren’t logged in and try to RSVP from an email link. It doesn’t seem to be fixed.

We are experiencing same issue for 2 days now. Any word on when the RSVP feature will be working again?

update 4/23: RSVP payment is broken again this week and we also can’t access the attendance>view all payments screen. This is one of our favorite features in TroopTrack that sets it apart from ScoutBook. Please fix - we need you! : )

1 Like

We are receiving the same message for all RSVP’s for Troop 1 Chicago; however, it is not only when attempting a quick RSVP from email. I receive the same message when logged into TroopTrack and selecting the event from the Calendar. Our events are set up with “payment required to RSVP”. The error appears when you click “Add to Cart”. I do not see any record of the RSVP being recorded from my admin view

Our troop is also getting the RSVP error, “We’re sorry, but something went wrong”. Would love to know what to tell them. Perhaps not to RSVP through the email link, but log on first?


We are having the same issue. We didn’t have this issue without being logged in first before the last month. I did note that the rsvps were being calculated even though members kept getting the error message.

I’m seeing the same error when I try to access the payments page for one event. I am able to access other events, but just one of them gives me the ‘sorry something went wrong error’ Therefore I can’t add youth to events manually for summer camp.