Import members

Is there a way to import or create new members from a CSV file?

We are recently flush with a 35 new member accounts from the Arrow of Light Cross over.

I was hoping to find an easier way to create new members in the future.

My thought was to have a Google sheet with a Form in front of it. To the new members - we would share a web link to the form. They then fill it out.

Then we export that Google Sheet as a CSV to matching fields on TroopTrack.

This would give us near instant and better accuracy on contact information about the new members.

I’ve got a year before the next cross over… so your attention to this would be appreciated before 2018.

We’ve talked about adding a feature like this in the past. It is something we would like to do, but there are things we have to work out first. If the scouts were in a TroopTrack cub account, we could just transfer them over, if not, I’m afraid it is going to be a manual process for now.

1 Like

I get it. Priorities. I don’t doubt your backlog being significant from the recent Rails upgrade. Guessing this would be item #534 out of 723 enhancement requests.

I wouldn’t put it that far back. Allowing users to do their own imports and transfers would help a lot of users and remove some of that manual burden from us.

Really need a way to import a lot of data from CSV.

  • Members
  • Equipment Inventory
  • Library Inventory
  • Camping, Hiking, Cycling, etc.
  • Training Records from BSA export

That’s my short list. There are probably more, as I begin to use TroopTrack.

We actually talked about this again on Monday. No timeframe for it, but we discussed starting with things like Equipment and Library imports and peeling those away from the current infrastructure to something more efficient so we can make this happen.

There’s an option to import users via CSV in the application. It’s not working, am I doing something wrong. Or does it not work?

Hi @EricMarcus,

This is a really old ticket. Can you please post what you tried and what the result was on the specific importer page you tried to use?

Thank you.

I know this is an old thread but in case people search for the same thing I wanted to update with the correct answer.