RSVP'ing to Events via the Calendar Announcement!

Hi TroopTrack Community,

This week a bug has started to occur of RSVP’ing for events through the calendar either giving an error message (when checking out with a cart) or just not working (when the event doesn’t require payment).

This bug is a top priority for our tech team, and they’re working hard to figure out what’s causing this and get it fixed. However; it is spring break in the location of TroopTrack headquarters, and some of our tech team members are on vacation. Nonetheless, our tech team expects to have this issue resolved by the end of the week and has already made major breakthroughs in getting this issue fixed.

We, at TroopTrack, understand the importance of the RSVP feature and rest assured our tech team is working tirelessly to get this issue resolved so your Troop can have a great experience using TroopTrack.


David Keener


Thank you for the communication and the great support!

I don’t know if this is the same issue or not. When someone clicks “going” or “Not Going” from the email announcement, it throws up the We’re sorry! But something went wrong announcement. But when you go into TroopTrack, the calendar is actually registering their choice.

That unfortunately has been broken for over 2 months now. Different issue, same headache.

Hi everyone,

The tech team has been able to fix the issue of RSVP’s not working on the calendar. This fix occurred late last Thursday, so there should be no more issues when RSVP’ing through the calendar.


David Keener

1 Like

@Keener-Trooptrack Troop 322 is still experiencing this issue. As well as getting the same error whenever /dashboard is opened, which means that logging in from or the mobile app doesn’t work. This makes the entire system unusable for most of our users. I opened a ticket for this (2278) on March 29 and got a response that it was being worked on, but there has been radio silence since then. I have emailed and called (leaving voice mails) several times and am not getting any response. Can I please get some help with this issue?

@Keener-Trooptrack can I please get a status on my issue? I just left another voicemail as well. Thanks!

We have had trouble with the RSVP for our tea party event, which is now past. However, I’m getting the “something went wrong” message when I try to record attendance for that event.

All the sign up issues seem to be resolved for my unit so I suspect it’s something local to your account. I’d be curious to know what it could be so I can verify that everything is good on my end as well.