Sub menus under Manage are not displaying

Im having the same issue. Trying to add a new member but when i click on members it wont open up to any options. I found a temp work around by going direct to units and adding a new member there.

1 Like

I’m also seeing this.

Experiencing the same issue here, tried multiple browsers

fwiw, this issue does not exist in the android app. Only in the web interface.

Same here. Tried in multiple browsers and have the same issue. What is being worked on to correct this?

Try that.

Same issue using Chrome (just updated).

August 14 and still not working - please fix :disappointed_relieved:

1 Like

I can find Add a new member at the bottom of the Dashboard menu.
I can get to Reports from Quick Nav.
But the typical drop down menus from the “Manage” button have disappeared.
Please look into this.
Thank you.
Simulating a mobile browser doesn’t seem to help me at all.

Really need this fixed as we are in the middle of recruiting season and we have to log out and log back in every time we need to add a prospective cub scout. Please fix ASAP!

I’ve been having this issue since last night. After reading thru this post, I tried to use the app to reactivate a family. I was able to get to the deactivated family, but it errored out as soon as I pressed “activate”. Since that didn’t work, I used my cell phone to log in to Troop Track via the browser, and it looked like I had full functionality. I was able to reactivate my users with no issues. Hopefully, PC access and the app will be fixed soon!

Same issue with Chrome, Brave and Edge. Please fix. Have a COH that I can’t print reports for.

Until this is fixed, the workaround that I posted works fine. I’ve tried the workaround on multiple browsers on both Windows and MacOS… chrome, firefox, edge all work! (haven’t validated with Safari)

It’s inconvenient, but it works…

Good luck.

Experiencing this issue in Edge and Chrome. It is very important that this issue is resolved ASAP; our treasurer needs to update our money account.

TroopTrack staff - Any status update? Is this issue being actively investigated?

Mobile view not working for me. Also there are issues with photo uploads (they don’t save). I wonder if this is a related issue. Regardless, there are some major bugs that are preventing routinely used features and we have not heard anything from staff? hmmm…

@dave @Keener-Trooptrack

Bringing this to your attention. Please address. Thank you!

Hi Everyone. Thanks for letting us know about this. We are working on a fix right now.



Hello again everyone. The sub-menu problem is now fixed. Thanks to everyone who reported this issue to us.


I’m having the smae issue

It’s fixed now, thanks for reporting it.