Adding members to TroopTrack

After the cutover to TL Connect? How is a member manually added to Troop Track, since we have the full version.

Hi @cstevens,

Have you taken a look at our user guide? In the user guide there is a section about adding members. Have you been able to try this out?

Let me know if you need anything else.


I have been using TT for few years. Now the option to add users since, Trail Life moved to Connect, the option is gone to add users.

Still waiting on your response. I am not able to add users.

Good morning! We added the ability to add members for Trail Life troops yesterday. Just click on the Manage badge to see your options.

Thanks for adding. How do we add the information about their status with TL? We can add an adult, but not able to make them a leader, since it doesn’t have the ability to show them as a registered leader. I have an adult that is registered leader in Trail Life in the last week, I added in Troop Track. I am not able to add a leadership role in Troop Track, since he is showing as non-registered.

Thanks for making progress on this. In addition to cstevens adult leadership issue, it seems no information can be input for anyone added. I’ve added a couple Trailmen to my roster and can’t update achievements because they show as not completing the registration process.

We will get that fixed in the next day or so. Thanks for everyone’s patience but there were many special rules in place between TroopTrack functionality and the national Trail Life features. Because all these rules are going away with Trail Life connect, we are now needing to reinstate all of these features to Trail Life TroopTrack accounts. Thanks for pointing all of this out. If there is anything else like this please make sure to bring it to our attention. Thanks for your patience with all of this.


@dcjohnsen and @cstevens both of your issues have been fixed. Please let us know if the problem still exists or if you need anything else. Thanks so much.

I still can’t view anything but profiles for Trailmen and adults I’ve added. Same message appears that the member hasn’t completed registration.

I can select and add the info for a new Trailman and click save but then the screen flashes and no account is created. I also have a leader that I am unable to update info for because not registered, see below.
Member Number: 2019-106971
Membership Expiration: 07/12/2020
CSYPT Taken On: 08/03/2019
Background Check On: 07/21/2019

Thanks for sharing @dcjohnsen and @Phil. There seems to be restrictions still in place coming from Trail Life. Our development team is look into this and I will update you when this is solved.

Looks like things are progressing. I can now view and input advancements for those Trailmen I’ve added since the TLUSA separation. However, each Woodlands branch/sylvan star has a duplicate that can’t be deleted. I know your team is working through the issues, just letting you know what I’m observing. Thanks for getting after this.


Are you still experiencing this problem?

A lot of the functionality for TLUSA TroopTrack accounts were originally missing because TLUSA National asked that some features were restricted for their troops. Now that TLUSA has moved to their own software starting July 13th, TroopTrack began the process to add functionality back to TLUSA TroopTrack accounts to return all the standard features. So far we have identified and fixed:

  • bulk achievements
  • individual achievements
  • editing personal info
  • provisional progress
  • access to same support resources as other TroopTrack accounts
  • remove leader pages (this was a request from national)
  • access to the dashboard
  • ability to delete people
  • ability to add members directly to patrols

We think TL troops are now on par with everyone else on TroopTrack but if you see anything that is not working correctly please let us know. Thank you so much



I see that the functionality is there. The issue I’m having is that a Forest Badge 2.0 or Sylvan Stars 2.0 for Woodlands Trailmen I’ve added since the split results in a huge list of duplicate branches. I tried deleting and restarting the Forest Badge and Sylvan Stars… the associated branches were removed and restarted, but the duplicate branches stayed behind with no way to delete them. See Victor Lightsey and Patrick Williams in Troop OK-0339.

Should I try deleting and re-adding the Trailmen to see if they reset correctly? Neither one has any achievements logged yet.



Hi @dcjohnsen,

It looks like the sub-awards for those achievements are acting strangely. It is indeed a bug. I have sent this to our technical staff and they will get to the bottom of it. Thanks for you patience as we diagnose and fix this.


I am still unable to add new Trailmen to our TT account. When I fill in the info and click save nothing happens.

I ran into this too. Might not be your issue, but if you haven’t input an address for the parent, the Trailman won’t save.

Oh, gotcha! I’ll give that a shot! Thanks

It worked! Thank you!