Photos uploaded not displaying

I have uploaded a batch of photos several times - about half are showing a broken image icon.

I have reduced file size to 5MB, and still have the same problem. I searched for what the supported JPEG file size and pixel limitations might be, but can’t find any details?

I just uploaded over 140 pics to an album for a recent campout. They started at broken image icon but eventually loaded.

My advice - give it a few minutes (like 2-3 tops) and then leave the album and come back in.

I’ve had no issues with this feature and have used it in the past few days.

Thanks - I have tried that, hours, even overnight.

I also created a new album and re-uploaded the entire batch of 34 photos. The SAME photos appear with the broken image icon - so clearly something is “off” regarding the jpeg images.

I shot with a Canon R5, and then used Lightroom to export as JPEGs - I tried limiting file size to 10MB, 7MB, and even 5MB… still unclear what the problem is, as uploading to other sites like SmugMug work just fine for the same images.

Looking to understand what (if any) parameters or restrictions are in place for TT.