TurboNet not responding

We are trying sync via turbo net today and everything just keeps spinning. Is there any issue that anyone knows of?

It is working, but we are having some asset issues at the moment. Just refresh the screen before you use turboNET and the animation will work.


I will have our advancement chair give that a shot. They have been watching the screen for 3 hours. :slight_smile:

This issue should be fixed and refreshing should not be required anymore

Thanks everything ran through perfectly.

I kicked off a TurboNet import, in order to sync up our scouts’ advancements. After clicking on the “Start Data Import” button, I got the page where it had the animated “Synching” and a progress bar that never advanced after at least ten minutes. I got nothing at all back other than that until I hit refresh, which brought me back to the “Import data from your council electronically” page.

Did anything really happen? Can you fix it so that there’s a bit more verbose status or progress reported? I had no idea if it was safe to even leave the page – or what happens if for some reason you leave the page or get disconnected after kicking it off. For all I know, I may have just entered a bad password. For what it’s worth, I’m using Safari on my iMac.

I just tried again, using Chrome. Never got the logging in status. Methinks something is wrong.

OK, it’s been four days. Is TurboNet broken, or is it me? My attempts still get stuck with no status messages, just the Synching animation.

Can you check the files tab on your profile and see if it saved any advancement reports there? I used TurboNET on Tuesday to report awards and it worked fine, but I had to refresh the page after it loaded, then enter my user name/password and select awards.

So… there was a bug that was causing the progress bar and updates to not work. I just pushed a fix for it.

Sorry for the hassle.



There were no files since the last time I ran it in September. I just tried it again, same behavior. Then I tried doing a refresh right after bringing up the page, and everything behaved perfectly — progress bar and details.

Jim Arndt

Thanks for letting me know @jarndt. Last night I pushed an update so in the future the refresh should not be necessary.


It is still not working. I sent a big advancement file on 1/17/17 and it wouldn’t provide any progress bar or details. Had to back out of the screen after several minutes. I logged directly into the BSA advancement system and looked at “prior reports” and I could see the 1/17/17 details. I sent a new small file on 1/18/18 and got same issue. This is still not resolved.

1 Like

I have tried to upload my advancement 5 or six times over the last couple of days and all I get is the “Updating” Graphic. I have let it set up to 30 minutes with no progress.
Is the system currently down. This worked in October.

Hi @DonaldAllen,

Please refresh the turboNET screen before entering your credentials and it should work. We are trying to find a fix for this.

I am also having issues with TurboNET. I have noticed that even though Troop Track shows updating… for hours, when I went onto the council site, the information was loaded and I was able to print a report from there. Not ideal but better than entering them all in again until this is fixed.


Please follow the instructions in the post above. Refreshing the turbonet screen before submitting a report will solve the issue until we can fix this.