How does a scout enter his rank progress info?

I only see a way for the scoutmaster to enter the information, this is for the scout himself to keep track of, not the scoutmaster. I being the scoutmaster have access to Scoutnet if I need his info… or do I simply import it from Scoutnet and the scout himself doesn’t enter it in TroopTrack?

sorry for the username too… I’m Mike Blanchard, not johnnyscout1… dunno how that one happened :wink:

Mike B

Hi @johnnyscout1 (Mike),

I’m not entirely sure I understand your question, so correct me if I’m wrong.

To import your scouts, go to Achieve > TurboNET Roster Import and enter your advancement ID and Password.

That will populate your account.

To give your scouts access (by default they will have self access when you invite them), go to Manage > Members > Invite Users. They will need email addresses. An email will be sent to them that will contain their username and it will prompt them to set a password so they can log in.

To give them access to change their own achievement records, go to Manage > Settings > Edit Troop Settings, TroopTrack Settings Tab and click “Let scouts edit their own achievement records” and hit “Update Settings”.


Go to Manage > Members > Privileges, Add Privileges, check the scouts names and give them the privilege “Edit Achievement Records”.

Let me know if I’m misunderstanding your question.

hi there!
I think that is what I’m looking for, I’ll check it out in the morning.

thank you!
Mike B

it says "logging in to internet advancement… then Import complete… however, trooptrack never actually imports anything…

any thoughts?

Will you please log into and make sure that all of your scout info is in there?

Thank you.

LOL, yah it’s all in Scoutnet…

is there anyway to export from Scoutnet and import into trooptrack?

ok, it’s importing now… I tried several things what worked in the end was for me to completely log out of Scoutnet, completely ending that session. Then logging into scoutnet so I get to the “load roster” screen again… then click on load roster… I immediately signed out of Scoutnet and into trooptrack, then did the import…and I see it importing everything now.

dunno what happend there… but I guess if scoutnet isnt’ left completely signed out, so the initial screen is “load roster”, trooptrack doesn’t know what to do at that point…

thank you for the help, you steered me toward fiddling with Scoutnet :slight_smile:
Mike B