PENDING: Unable to login on the new TT4 mobile app

I’m not sure if it’s just me or everyone, but the mobile app updated and logged me out. I am unable to log back in using the app.

I have been able to log in on the same phone in the web browser and on my PC in a web browser, so I know my credentials are good. In the mobile app I get a screen that says “Login Failed Try Again”.

killing the app and re-lanuching had no effect.

Same for me. I get the same message when I try to log into the new TT4 mobile app.

I’m having the same issue with the new app. I’m excited to check it out, but will have to keep using the browser on my mobile instead. :roll_eyes: Hopefully, it’ll be resolved soon!
I’m running latest Android OS.

Thanks everyone. I’m working on this over the weekend. Hopefully I’ll get it figured out. On iOS, killing and restarting the app resolved the problem, but that doesn’t seem to do the trick on Android.

I followed these instructions to kill TroopTrack mobile on android, then restarted it and it worked:

It’s not as simple as just closing and re-opening the app. I had to actually shut it down.


Following the instructions in the Lifewire link you supplied to close/kill the app worked for me. I can now log into the TT4 mobile app.

1 Like

I have released a new version of the app that should fix this problem. It can take a while for it to be available in google play, but once version 4.0.3 is available this problem should go away.

Thanks everyone!