Achievements not appearing correctly

One of my Cub Scouts, Jack, does not have the correct achievements.

His records say items are completed but note some have 2015 and some 2016 at the end. Could that be why they didn’t have him achieving anything yet? Are we updating the wrong section or are we setup incorrectly? Looks like the badge is listed as 2015 but the updates have gone in as 2016. What is the best course of action to correct this?

Jack has received Bobcat.

He has completed but not received the following:

  • Call of the Wild
  • Council Fire
  • Paws on the Path
  • Adventures in Coins

Many thanks for any assistance you can provide.

Forgive me, I don’t completely understand the question.

Anything that was completed under the 2015 requirements should be marked as such and anything under the new 2016 requirements should be marked with those.

I looked at your scout and I didn’t see anything wrong with his achievements. Just let me know how I can help and I’ll see what I can do.

Thank you.

I am having the same problem. I have been entering every achievement in the new 2016+ but it is not reflecting in the rank. The rank progress reads only 5% done but they are more like 80% done. Help please.

Jennie McJilton

The new 2016 ranks are not connected to the 2016 requirements yet. We had to postpone that feature. For now, when an adventure is complete, you need to mark it as complete in the rank.

Thanks. But why would this only happen to one of my scouts and not the

I’m not sure what you mean. The 2016 requirements are available to everyone. Someone may have recorded one type of requirements for some and the other for the rest.

Hi I am having trouble with the 2015, 2016 requirement logging. I have marked the requirements complete but it is still not showing up and when I tried to get it to go to Turbonet this last month it didn’t go I had to stop the process after waiting over 15min. and just printed the shopping list and didn’t get the right awards, I got duplicates and totally missed some others. I need so help please.
Jennie McJilton Pack 377

The tuboNET issue can be resolved by refreshing your screen before submitting the report.

I’m aware of a few of the 2016 requirements not showing up and we are trying to figure that one out. In the meantime, just mark the 2015 version as complete and submit that one.

Thank you.

When will this 2015/2016 issue be resolved? It’s really confusing many of my parents.

Nope. Sorry, I don’t have an estimate. The ticket is marked as “Critical” though.