FIXED: Events will not allow registration

Scouts cannot register for an event because when they attempt to use funds in their account to pay for the event, it provides a warning message that “token is invalid” and does not allow the scouts to register for the event. This has been seen by multiple families in our troop.

In addition, in the check-out screen, Trooptrack automatically charges fees for anyone attempting to purchase the event. When scouts want to use funds already in their account, this should not be the case as they are not using PayPal for payment and the funds are already in the scouts account.

Thank you

1 Like

To add a bit more detail to this post for Troop 109, I have recreated the issue. An item or items are added to the cart.

When you navigate to the cart to check out and click the “Check Out” button, the next screen shows a total for each item, plus a transaction fee. Following that is the total of those items including the transaction fee. I think the confusing part about this is that it is not clear that you probably won’t pay the transaction fee unless you have a credit card payment option turned on and use that. In our Troop, we do have PayPal turned on, so I imagine that is why the fee is showing up. On the right side of that page, there seem to be two options for paying. The first option at the top is boxed in and looks to be for paying from a Money Account. There is a blue “Pay Now” button with white text. The second option just below the first has a warning about how to successfully use PayPal to complete a payment, followed by a “Pay Now” button in yellow with black lettering. This looks like the PayPal option for payment.

If I use the first option (blue Pay Now button) associated with the “Pay From a Money Account” area, the screen changes back to my “Your Dashboard” view and an error bar message briefly shows up with the message “The token you tried to use is invalid”. It quickly disappears and I can still see that my cart has 3 items in it (top of the screen cart icon with count overlay).

When I click on the cart, the navigation back to the shopping cart shows me that the items are still in the cart.

I just tried turning off the credit card payment option and there was no change in the results besides the fact that the second payment option noted above in the 2nd screen shot/image in the previous post was missing (the “PLEASE READ!!!” and “Pay Now” yellow button with black text). The next screen was still the dashboard with the invalid token message.

Follow. Our troop is having the same issue with the new cart.

Following. We’re having the same issue.

Agreed, we are also seeing the RSVP process charge a fee for Money Account when there should be no fee.

Hello all,

We have confirmed this bug and I wanted to let you know this is the issue we are tackling next. Our tech team were finishing some other issues, and this is next on the list.

Sorry if this is causing inconvenience, but I will be sure to keep you updated on this thread.

Thanks,
Tyler
TroopTrack

Hello,

This bug has now been fixed. We have confirmed it on TroopTrack’s side but we would love confirmation from the users who were experiencing the invalid token message.

Thanks
Tyler
TroopTrack

Hi Tyler,
It appears that Trooptrack is still adding on fees for those who want to pay with funds from their money account. So I do not want to check out to reach the “invalid token” page because it will over charge.

Thanks,
Anthony

1 Like

@Tyler, I was able to successfully complete the check out process.

@Tyler I’ll also confirm what Anthony said. When someone charges their personal account. The transaction fee also is added. This is incorrect and would overcharge a person’s account.

There is still a problem with this process. I have an event with a fee and requiring payment to RSVP, we do not use PayPal or Stripe. I select Purchase Ticket/RSVP and get the option to select Going, Not Going and add youth or adult guests, select Add to Chart. I then select check out and see the total in the cart and check out, select my Money Account and Pay Now, I get my receipt. Going back into the event it shows me as RSVPd however does not show paid and if I go to the Payment History for the event it shows RSVPd without purchasing, even though I have the cart transaction in my account.

@AaronStorey Can you check to see if the payments show up on the Event -> Payment page now? I pushed a fix. Thanks!

It stills looks like the problem exists. I tried to check out with a money account, but the transaction fee is still showing at checkout.
Thanks… Anthony

@dave, sorry the payment still does not show up on the Event -> Payment page. In case it matters I went into the Event Payment page and selected Refund. My RSVP went away and the payment was removed from my Money Account. Then I went through the RSVP/Payment/Cart process and same thing. Still wants me to Purchase Ticket/RSVP and the Payment shows RSVPd without paying.

Ugh. This is working for me locally. Would you be able to chat via video conference and share your screen with me tomorrow evening or some other night?

Yes, I am available tomorrow evening, I will also do some more testing tomorrow as well.

1 Like

First off, thanks to everyone who helped us understand this problem better. Here are all the problems that were fixed tonight:

  1. Transaction fees were incorrect. Math is hard!
  2. Transaction fees were being applied to money account payments.
  3. Tickets were not available to a user after making a purchase.
  4. Token errors were preventing people from checking out.
  5. The transactions did not show up on the event payments page.
  6. The transactions did not show up on the ticket.

That was rough. I’m sorry this happened. I know some of you will need to manually refund some payments and correct some accounts. Please accept our apologies.

Best,

Dave