Meeting Schedules not showing up in the Calendar

I’ve played around a bit with the Meeting Schedule feature but am stumped as to why events I create there don’t show up on the calendar for my unit. Am I missing something obvious? Are these functions not integrated?

When you look at your calendar, at the top you have these 3 little icons, did you try and click those? I know some of our stuff didn’t show up until I changed it to the “world icon”.

Hope that helps!
Crissi

I never even noticed those icons before. Neat.

I did just try it. Looks like it was already defaulted to “All Events” (the world icon). Meeting Schedule events still aren’t there. I toggled back and forth between all the icons as a Hail-Mary thinking it might “shake something loose” but it didn’t. I also tried fiddling with the event- toggling RSVPs on and off, and making sure everyone was invited also did nothing.

This seems like a really huge oversight to have Meeting Schedules not appear on the calendar.

Strange! Our meeting schedules show up.

Do you leave your TT open in your browser a lot? I always have a tab with TT open since I’m in it on a regular/daily basis. Apparently, it likes to have the browser restarted occasionally. :smirk: I’m guessing once a week/2 weeks isn’t enough. lol I especially have problems if I have had it open for days (ahem, weeks) and then suddenly start entering all this bulk stuff. Most times just restarting the browser helps.

I tend to use Trooptrack in spurts, so it isn’t usually hanging around in an open tab/window. I’m able to reproduce the problem across four different browser applications, three different machines, and two different operating systems. :confounded:

Dunno if any TroopTrack staff are reading this, but on the off chance that there was something wrong in the database with the schedule I’ve been working with, I created a new one- to no avail. It doesn’t show up on the Calendar either.

I’m subscribed to our troop’s calendar feed in Calendar.app on OS X 10.10, and I don’t see Meeting Schedule events there either, though I do see regular calendar events as expected.

This post was flagged by the community and is temporarily hidden.

Boy do I feel dumb. I had been completely missing the second Save Events button. The test event is showing up in the feed and web calendar UI now.

Thanks! I figured it must have been a user malfunction on my part when @SRUEDU said it was working for them. :disappointed_relieved:

This post was flagged by the community and is temporarily hidden.

I was having the same problem and even when I clicked “Save Events” I wasn’t seeing the event appear in the calendar. After going back and looking closely, I realized I hadn’t specified who was invited to attend. As soon as I selected “Everyone” and saved, the event popped up on the calendar.

I don’t know if this is the same problem, but I am having trouble viewing calendar items. What am I doing wrong?

When I first look at my calendar, this is what I see for my Family Member calendar (no entries on 1/19 or 2/2):

But when I click on the All Events calendar (world icon), I see entries for 1/19 and 2/2:

These are troop meetings, which everyone is invited to, or should be invited to. When I click on the meeting, and then “Details & RSVP,” I see my daughter’s name and my name listed as invited, but No RSVP’s are necessary. When I click the back arrow in my browser to take me out of the Details & RSVP page, the calendar reloads with the Family Member calendar showing, but now the meeting that I just clicked on (1/19 in this case) is now showing:

Note that the 2/2 meeting is still not showing.

What do we need to do to make sure that all of these meetings are showing up on everyone’s calendars?

Thanks!

Any thoughts on this problem? It is still happening. I can only see certain events if I click on the world icon. They do not show up on the My Events calendar, or my Family events calendar.

Thanks!

@mwestcott,

Updating the events should solve this issue. You should be able to solve them all at once through the Plan > Meeting Schedules feature or individually by pressing edit on the calendar for that event and just pressing update.

Thanks - can you clarify which exact steps need to be done? I did not create these repeating meetings, and I do not want to update them myself. I would like to send the meeting creator the steps to fix the problem.

From Plan > Meeting Schedules, what should she click on: “Edit Schedule” or “View/ Edit Events”?

Thanks!

Edit Schedule, Save or Update, Save or Update again and that should be it.

The person who entered these meetings updated it as you specified. Now none of the future events are showing up in my “Events a Family Member is Invited to.” When I click on “All Events” calendar, the regular troop meetings show up.

I do receive the meeting reminders which are sent the day before.

Seems strange that none of the regular meetings show up for me. Is it because no RSVP is required?

I just updated one of your meetings and it appeared after that.

hmm. I am not seeing any regular troop meetings on my “Events a Family Member is Invited To” for February, March, or April. The upcoming January meeting is showing up now. I wonder if that is the one you updated?

Thanks!

Yes. Just press “All Events” to update individually or you may go to the meeting schedule and just update that by editing and saving it and they should all show up.

Thanks for your help on this issue. I understand that if I go to All Events, and manually update every meeting, I will then be able to see the meetings in my calendar. My question is, is that the way it is supposed to work? I just feel like something is wrong here.

I know you haven’t been able to duplicate this on your end, but I just saw a similar post under “Calendar Help Needed” so I am not the only one with this issue.

I am going to have a hard time telling other families that in order to see meetings in their “My Events” calendar, they have to go to the “All Events” calendar, find the ones that apply to them, and then update each one individually.