Missing Cub Scout NOVA -- 1-2-3-GO!

I was using the bulk record progress function and could not find the Cub Scout NOVA “1-2-3-GO!” in the selection. I then went to an individual scout and tried to start achievement on it and could not find it. Would it be possible to add this award to the trooptrack database?

Thank you
Pack 873

Hi @ptemberton,

I am going to assign this to our awards specialist @melissa. She will get it done in the next couple of days and let you know when it is available.


Hello @ptemberton

The award should show up for you now. It was not selected as an award in use in your settings. I selected it and updated your troop settings.

Let me know if you have any other troubles with this!

Thank you melissa. when I went into today, it was not selected I tried to select it and update. It look like it took it until I went to update a scout. It was not in the individual or bulk update section.

Hi @ptemberton

I tried to do it again today and it is not working for me either. It is a bug in our system. I will have this issue looked at and fixed! So sorry about that!