Not Showing Member Emails in Messages

How do I send a meeting or event reminder email without it showing everyone’s emails in the body of the message? It runs into the actual message and makes finding the information difficult.

Perhaps you could include a screenshot, removing personal info, of what you are seeing. In my experience e-mails sent either automatically or manually only show an individual To: address, not everyone. If you are sending an e-mail manually you as the sender get a confirmation message that shows everyone but that only goes out to the originator of the message not to all the recipients.

Agreed, the only time I have seen anything like this is the email I get sent to show who the messages were sent to (confirmation email).

Here is what all of us received as a meeting reminder email…

I realize it’s not that it shows everyone’s email but that it shows everyone’s name and then finally gets to the email. Just wondering if there is a way to just show the reminder info and not all the header stuff.

I have never seen a message with so many listed like that. When I get a message, it shows the members of my household, in that same space.
Perhaps check to see if someone has really messed up households and added everyone to yours or you to everyones? If there isn’t anything wrong in the households then I would suggest sending an email to and copy that screenshot, that is definitely not how it looks in my experience, and I couldn’t find any settings for a meeting that would account for such a long list.

1 Like

@karenburgos, Has there been any response or update on this? I am curious what the problem was/is.

Yes. It turns out what it was showing is everyone in the same “household”. I just removed everyone from that household and created a group message id. Not sure how so many people ended up in the same household but now I know what to do if I see it again.

I would suggest you talk to the other Admins from your group to see if you can find out who is adding everyone to a single household and why.