PENDING: Scout Made Payment On App - Did Not Mark Them As Going

I had a scout make a payment today through the app. This seems to be a continuing problem with payments from PayPal. I’ll try to break down what I’m seeing. This needs repair badly.

  • I receive payments on PayPal. The transactions clear on the PayPal side but there are no identifying notes as to what those payments go to other than a long order number that I now need to go and cross reference back to TroopTrack. That’s not a big deal but I am finding it near impossible to figure out what I need on the TroopTrack side. Leading me to the next observations.
  • With these transactions, I first look at the individual events. But unfortunately, there is no record of the payments in the event’s “Payment History” page or any RSVP markings for that member as “going” for that event.
  • Nothing seems to be listed under the “Primary Account” for this transaction either.
  • I finally see things listed under the “Orders” page but under the payment method it says “Not Purchased” for things that, I think, went through PayPal. This is wrong because they did in fact make the purchase. The items that were charged to an internal TroopTrack account, I think, are coming through ok. Are these items that say “Not Purchased” under the “Orders” page stuck? If they aren’t then why are these orders not associated with the event they were paid under?

I remembered that in order for TroopTrack to mark the RSVP, the end user needs to wait a second or two after the PayPal confirmation page. Paypal then pushes the user back to TroopTrack marking the RSVP and completing the transaction on the TroopTrack side. After doing some work and talking with the member who paid, I do think it has something to do with being on the mobile app. When the user is on the app, its pushing them to sign on to TroopTrack through their mobile browser instead of pushing them back to their already opened TroopTrack session on the mobile app. The user is getting confused and not doing that secondary sign in on the browser. I think that’s the major issue here.

One alternative thought…
Is there any way to capture the RSVP on the front side of all this? That way when the payment is complete it doesn’t matter what the user does, we already have their RSVP on TroopTrack. It just seems like a difficult ask to expect users to remember and allow the push back to TroopTrack from PayPal every single time. It just seems like this will be a forever-headache for admins having transactions not being processed completely.

Thanks Justin. I just published an update to the mobile app that fixed this for me. I changed it so that it doesn’t launch PayPal in the browser anymore, which allows it to redirect back to TroopTrack after paying.

You won’t need to update the app, but you might need to restart it before the changes will work for you. Please try it again tomorrow and let me know.

Also, very nice sleuthing @JustinWeaver!!! Thanks so much.

Hi Dave,

Thank you. I just want this platform to be the best it can be. If that means some legwork on my end, so be it. I’m happy to do it.

I tried to make a payment through my phone on the mobile app. It does seem that PayPal is now launching within the TroopTrack app which is great!

One sidebar item to note, It seems that the “Pay With PayPal” button is not very responsive. I tapped once, waited for 20 seconds and nothing happened. I tapped twice, waited 5 seconds and nothing happened. I tapped thrice and it finally came up. This may be a headache point for the end user, especially without any sort of loading animation or indicator.

When the PalPal screen comes up, It gives you the option to either pay with PayPal account or to pay with a debit or credit card. The majority of my users just pay directly with a card and do not log into an account, so that is what I chose as well.

This is where the problems begin.

When I click on “Pay With Debit or Credit Card” it seems like is trying to load the screen but fails. You get the PayPal loading animation and than a “Try Again” screen for just a second and then it seems to attempt a log in again. But, you are again at the same “Try Again” screen and then in bumps you over to the Security Challenge captcha. I click on the “I Am Not A Robot” checkbox but when I do the whole app freezes.

I think we’re on the right track here. We just have some bugs to squash.

That’s the flow I tested (paying with a card without logging in) and it worked for me, but I had to restart the app before it would work.

This is a pretty old version of the PayPal API we are using. Updating to the latest would require everyone to set up their PayPal payments with TT again, but maybe it’s time to just bite the bullet.

I’m not sure I follow what you mean by setting up paypal payments with trooptrack.

I attempted a payment again. It’s actually really odd. This time, it only brought up one “Try Again” screen and then it opened the page to enter in card details. Wanting to see if this was just a fluke, I closed the app completely, relaunched it, and went through the same process again. This time, I had the original experience I outlined before. It seems that the flow is not producing consistent and stable results.

The new PayPal flow for merchant accounts like this is different, so once I upgrade to the new PayPal API your payments won’t work until you authorize TroopTrack to send you money.

Every single transaction or just once at setup?

Just once at set up. Then everything will work.

Gotcha! That doesn’t seem too bad.

By the way, I do want to thank you and your team for being so responsive and building the best scouting platform out there. I’m sure you hear more complaints than thanks as developers. I’m thankful for all you are doing for the Scouting Movement. Having partners like you help make our job as leaders on the “front lines” with the youth so much easier. :slight_smile: