Site broken - urgent

The site is massively broken. This is all I am seeing. I have tried this on both Chrome and Edge with the same result.

This issue is not a global issue it seems to be specific to some individuals. It does appear to be an SSL issue with the certificate for some users are getting errors loading the certificate.

I’ve tried on multiple devices using multiple browsers. The issue persists.

@JustinWeaver, are you still having an issue getting the TT site to load properly?

I’m having the same issue. It worked yesterday but today, anything I click, gives me the same screen as @JustinWeaver. I can’t access anything else. I’m using Brave browser, updated. But it doesn’t work on Safari either.

Today my issue is fixed. Yesterday, after I posted it would work off and on. Today, I haven’t had any issues. YAY!

Same experience. The GUI was totally screwed up on the laptop as well as mobile version. Then literally started to work on the same day.

Right for some reason some parental controls systems blocked one of the sites that TT uses to host part of its site. I believe Dave fixed it by changing where the files were hosted.

I’m experiencing the same issue on our site. Inspecting the NETWORK tabs from developer tools seem to be a broken link to CSS style and a logo.

Looks like they were doing some work. It is back up.

Thanks, yeah it is back up now.

Earlier today, I started getting the same thing JustinWeaver shows in his original post in this thread.

I finally figured out that Malwarebytes is blocking the site “”. If I “safelist” that website, the TroopTrack returns to normal.

Here are screenshots from Malwarebytes.