Venture Scouts award input?

Why am I not able to input awards for Venture scouts? I can create a venture patrol, but I’m not able to input any of their achievements.

Hi @MarquitaHolmes1,

Go to Manage > Settings > Edit Troop Settings, Charter Organization Tab and click the checkbox next to LDS Unit, then “Update Settings”. This should allow you to input the Venture achievements.

Let me know if you have any trouble with this.

Hello and thanks for your help! How long should it take for settings to update? I followed the instructions to you gave and it said that the settings were updated successfully. I tried it out, but nothing seemed to have changed. Then I logged out and logged back in, but still nothing changed. I can see Varsity awards, but not Venture. None of the ranks are there either. Did I miss a step?


I’m going to take a closer look and talk to our awards specialist about this and get back to you.

Thank you.

I have no option to add Venturing Awards, LDS, etc. We are a ventureing crew and have boy scout ranks listed instead of venturing awards. Can you let me know how to handle?


Hi @LyleF,

Did you register as a Boy Scout Troop or as a Venturing Crew?

Registered as Venturing Crew,

This was verified by Scott at the help desk. He said there is a bug and that I should start here to try and resolve.


I’ve had the same problem for quite some time. They haven’t been able to resolve the issue apparently.

Which awards can’t you input? I don’t seem to be having any trouble, but I’m not entirely sure what to look for.

I was told by Scott that at the help desk that I should be able to delete
these scout ranks
so they didnt show and that this was a bug so I should report under bugs.

Oh, I see.

I don’t know who Scott is, but we are aware of this specific issue and it has been reported.

Thank you.

I’m not seeing ANY venturing awards.

Select youth profile you want to update - Achievements (tab)- Other - Start
Achievement - check box of award you want to activate.

I’ve tried that. I think there may be something wrong before that step. We are a troop with venture scouts. I have the venture scouts in a venturing patrol, but is there some sort of other designation I may be missing? No matter what I select, I only see scout and varsity awards.

Hi @MarquitaHolmes1,

It doesn’t appear that you have a Venture Crew associated with your user name. You may have accidentally created a Troop instead of a Venturing Crew.

How do I fix that? There is a Troop 343 and a Crew 343. Someone told me that there was an LDS option to keep everything together. How do into about doing this?

In reading this post. Do we need to have separate accounts for a Troop and Crew? We are testing Trooptrack with our Troop 67 but I will be starting Crew 67 in the next couple of weeks. I didn’t want to buy two seats of the program.

Thank you

If you’re an LDS unit there is a beta hybrid program you can check out by going to Manage > Settings > Edit Troop Settings, Charter Organization, “LDS Unit” checkbox.

But you may need to get both the troop and crew as separate accounts if this doesn’t work. In either case, you will have separate Scoutnet IDs and Passwords. You will have to use the troop’s for the troop and the crew’s for the crew.

Thank you.

We are not LDS. I guess we will look at buying two seats of TroopTracks. I was hoping to set the Crew up as a patrol.

Thank you for the help.

If it helps anyone else trying to have your Troop and Crew under one TroopTrack account. I have gone into Manage/Settings/Custom Awards/Create A New Custom Awards. Then you are given the options for Name & number of requirement. Then start entering the descriptions and so on. Yes it’s a lot to type but for now it works. Your Crew is small to start with zero $ and we work closely with our Troop.