Internet Advancement 2.0 Integration Preview

We are in the final stages of building our Internet Advancement 2.0 Integration, but we’re far enough along to be able to share a preview video with you.

Please let us know what you think. We expect to release this feature over the Fourth of July weekend if all goes well.

1 Like

Thank you, this is great. As a point of clarification, according to the video and discussion forum post linked below the files are processed hourly, @Dave did you get other information from BSA in your communication with them? Not as clean as the previous process but better than nothing. Hopefully they will also work on developing other options or decrease that timeframe.

The document they gave me said they were processed overnight. I would expect the forums is more accurate and up-to-date.


Great video thank you for producing this. Maybe I am just focused on the terminology used. Is this the same process for Cub Scouts as well? I am only involved with Cubs at this point.

Thank you.

Yes, the process is the same for cub scouts. Great question!

Great to know thank you

Thank you!!

Will there be a method to upload either Scout book or IA 2.0 data INTO Troop Track?

This depends on BSA’s rollout of their API. Does ScoutBook currently have any way to export your roster?

I’d like to know if others have tried this with success.
This being downloading the file from TT and uploading the file to IA2.0. I can down load and view the file.
Oddly, it is pipe delimited, not tab or comma? BSA isn’t publicly releasing the file format so I can’t independently verify.
IA2.0 gives an error message when uploading the file but then doesn’t display an error in the window. I’ve tried multiple times in two browsers (Chrome and Safari).
The Scouting Forums seem to imply that TroopMaster and PackMaster are working, but TT isn’t.

Hi Keith,
Thanks for trying it out. Could you share the specific error message you received to help us figure out what went wrong?

The pipe-delimited format is correct per BSA’s documentation, though I admit it’s a little unusual.



That’s the weird thing. There is no error message detailed. This tells me there is an error.

But the detail is blank. I even click the “Copy to Clipboard” and nothing goes to the clipboard.

Same situation occurs in both Safari and Chrome.

Also, for kicks and giggles, I tried the following…
Deleting the header line in the txt file.
Deleting all but one scout in the txt file.
Deleting the header line and all but one scout in the txt file.
…none of that worked either.

The “version” field in the txt file is blank. Should it be?

Yes, the version should be blank, per BSA. It’s weird.

Would you mind sharing a link to the forum that says this is not working for TroopTrack?

I’m going to need to submit your file to BSA for analysis. Could you email the following info to please:

  • The original unmodified file
  • The respective unit type, unit number, unit charter
  • The Name and member ID of the unit leader

If you send that over, BSA will manually test the file and tell me what the problem is without making any changes to your troop.


Yes, it does. Roster, advancement and service hours can be exported in csv format.

If you will send sample files to we will build importers for them. Thanks!

I just got this from BSA:

there’s a bug right now which prevents the UI from displaying the error. We have some code ready to fix the issue, hopefully we’ll have it pushed today. After that, the unit can try uploading the file again and see the error in the UI.

So, maybe try it again later today?

Here’s one of the links talking about the file upload…

I’ve been crawling all over the TT and BSA forums looking for any nuggets about working with IA2 so I probably also saw it elsewhere. I appreciate your effort to make it work. Good thing this happened over the summer time. The troop is pausing our advancement records until the TT to IA2 integration is working.

I’m not willing to share the TT upload file through you to BSA due to it having youth names and BSA IDs. However, if you open a case with them and tell me who the support tech it, I’ll send it over direct to them. Then the data stays inside BSA. Hope you understand.


Thanks. No worries about the file - BSA says they are fixing a bug on their end that was preventing the error from being displayed and that it should go live today. Once that happens, you can try again.

Did you try it again?